Photoshop-Double Exposure Action 11912666

GraphicRiver – Double Exposure Action 11912666
Photoshop ATN | Works With PSD | Minimum Adobe CS Version: CS3 | 805 Kb

Tested and optimised for use on Photoshop CS3, CS4, CS5, CS6, CC